We are no longer offering accounts on this server. Consider https://gitlab.freedesktop.org/ as a place to host projects.

Commit c5e89527 authored by Brion Vibber's avatar Brion Vibber

Updated OMB_Yadis_XRDS for compatibility with php-openid 2.2.2:...

Updated OMB_Yadis_XRDS for compatibility with php-openid 2.2.2: Auth_Yadis_XRDS::parseXRDS() is now declared static, and PHP 5.3 demands it say so on the subclass too.

Compat fix branch for upstream: http://gitorious.org/libomb/libomb-statusnet/commit/6589dc073f93b65564931e1ab5865a34a0b228aa
parent 15b1d130
......@@ -155,7 +155,7 @@ class OMB_Yadis_XRDS extends Auth_Yadis_XRDS
* @return mixed An instance of OMB_Yadis_XRDS or null,
* depending on the validity of $xml_string
*/
public function parseXRDS($xml_string, $extra_ns_map = null)
public static function parseXRDS($xml_string, $extra_ns_map = null)
{
$_null = null;
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment