We are no longer offering accounts on this server. Consider https://gitlab.freedesktop.org/ as a place to host projects.

Commit 98f0d970 authored by Zachary Copley's avatar Zachary Copley

Update release notes and version number for 0.9.2

parent c48caa85
......@@ -2,8 +2,8 @@
README
------
StatusNet 0.9.1 ("Everybody Hurts")
28 Mar 2010
StatusNet 0.9.2 ("King of Birds")
21 Apr 2010
This is the README file for StatusNet, the Open Source microblogging
platform. It includes installation instructions, descriptions of
......@@ -77,7 +77,7 @@ for additional terms.
New this version
================
This is a minor bug and feature release since version 0.9.0 released 4
This is a minor bug and feature release since version 0.9.1 released 28
March 2010.
Because of fixes to OStatus bugs, it is highly recommended that all
......@@ -85,26 +85,23 @@ public sites upgrade to the new version immediately.
Notable changes this version:
- Twitter bridge truncates and links back to original for long
notices.
- Changed "Home" link in main menu to "Personal".
- A new memcached plugin (using pecl/memcached versus pecl/memcache)
- Opt-in subscription to update@status.net
- Script to run commands on behalf of a user.
- Better Web UI for long notices.
- A plugin to open external links in their own window or tab
- Fixes to Salmon protocol for compatibility with other systems.
- Updates to latest ActivityStreams definition.
- Twitpic-compatible API for image upload.
- Background deletion of user accounts.
- Better support for HTTP basic authentication with CGI/FastCGI
- Better discovery on OStatus
- Support for PuSH-enabled RSS 2.0 feeds
- OpenID-only mode
- OpenID blacklist/whitelist
- OStatus unit tests
A full changelog is available at http://status.net/wiki/StatusNet_0.9.1.
- Fixed email notifications for @-replies that come in via OStatus
- OStatus related Fixes to the cloudy theme
- Pass geo locations over Twitter bridge (will only be used if enabled on the Twitter side)
- scripts/showplugins.php - script to dump the list of activated plugins and their settings
- scripts/fixup_blocks.php - script to finds any stray subscriptions in violation of blocks, and removes them
- Allow blocking someone who's not currently subscribed to you (prevents seeing @-replies from them, or them subbing to you in future)
- Default 2-second timeout on Geonames web service lookups
- Improved localization for plugins
- New anti-spam measures: added nofollow rels to group members list, subscribers list
- Shared cache key option for Geonames plugin (lets multi-instance sites share their cached geoname lookups)
- Stability fixes to the TwitterStatusFetcher
- If user allows location sharing but turned off browser location use profile location
- Improved group listing via the API
- Improved FOAF output
- Several other bugfixes
A full changelog is available at http://status.net/wiki/StatusNet_0.9.2.
Prerequisites
=============
......@@ -216,9 +213,9 @@ especially if you've previously installed PHP/MySQL packages.
1. Unpack the tarball you downloaded on your Web server. Usually a
command like this will work:
tar zxf statusnet-0.9.1.tar.gz
tar zxf statusnet-0.9.2.tar.gz
...which will make a statusnet-0.9.1 subdirectory in your current
...which will make a statusnet-0.9.2 subdirectory in your current
directory. (If you don't have shell access on your Web server, you
may have to unpack the tarball on your local computer and FTP the
files to the server.)
......@@ -226,7 +223,7 @@ especially if you've previously installed PHP/MySQL packages.
2. Move the tarball to a directory of your choosing in your Web root
directory. Usually something like this will work:
mv statusnet-0.9.1 /var/www/statusnet
mv statusnet-0.9.2 /var/www/statusnet
This will make your StatusNet instance available in the statusnet path of
your server, like "http://example.net/statusnet". "microblog" or
......@@ -641,7 +638,7 @@ with this situation.
If you've been using StatusNet 0.7, 0.6, 0.5 or lower, or if you've
been tracking the "git" version of the software, you will probably
want to upgrade and keep your existing data. There is no automated
upgrade procedure in StatusNet 0.9.1. Try these step-by-step
upgrade procedure in StatusNet 0.9.2. Try these step-by-step
instructions; read to the end first before trying them.
0. Download StatusNet and set up all the prerequisites as if you were
......@@ -662,7 +659,7 @@ instructions; read to the end first before trying them.
5. Once all writing processes to your site are turned off, make a
final backup of the Web directory and database.
6. Move your StatusNet directory to a backup spot, like "statusnet.bak".
7. Unpack your StatusNet 0.9.1 tarball and move it to "statusnet" or
7. Unpack your StatusNet 0.9.2 tarball and move it to "statusnet" or
wherever your code used to be.
8. Copy the config.php file and avatar directory from your old
directory to your new directory.
......@@ -1499,7 +1496,7 @@ repository (see below), and you get a compilation error ("unexpected
T_STRING") in the browser, check to see that you don't have any
conflicts in your code.
If you upgraded to StatusNet 0.9.1 without reading the "Notice
If you upgraded to StatusNet 0.9.2 without reading the "Notice
inboxes" section above, and all your users' 'Personal' tabs are empty,
read the "Notice inboxes" section above.
......
......@@ -22,7 +22,7 @@ if (!defined('STATUSNET') && !defined('LACONICA')) { exit(1); }
//exit with 200 response, if this is checking fancy from the installer
if (isset($_REQUEST['p']) && $_REQUEST['p'] == 'check-fancy') { exit; }
define('STATUSNET_VERSION', '0.9.1');
define('STATUSNET_VERSION', '0.9.2');
define('LACONICA_VERSION', STATUSNET_VERSION); // compatibility
define('STATUSNET_CODENAME', 'Everybody Hurts');
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment