We are no longer offering accounts on this server. Consider https://gitlab.freedesktop.org/ as a place to host projects.

Commit 8894f957 authored by Craig Andrews's avatar Craig Andrews

Require PHP 5.2.3 or later.

http://laconi.ca/trac/ticket/1605
parent f0d17afc
......@@ -134,7 +134,7 @@ Prerequisites
The following software packages are *required* for this software to
run correctly.
- PHP 5.2.x. It may be possible to run this software on earlier
- PHP 5.2.3+. It may be possible to run this software on earlier
versions of PHP, but many of the functions used are only available
in PHP 5.2 or above.
- MySQL 5.x. The Laconica database is stored, by default, in a MySQL
......
......@@ -43,8 +43,8 @@ function checkPrereqs()
$pass = false;
}
if (version_compare(PHP_VERSION, '5.0.0', '<')) {
?><p class="error">Require PHP version 5 or greater.</p><?php
if (version_compare(PHP_VERSION, '5.2.3', '<')) {
?><p class="error">Require PHP version 5.2.3 or greater.</p><?php
$pass = false;
}
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment